[arm-allstar] Subject: Newby instructions for playnews

AN andy at neu.net
Wed Sep 2 21:13:17 EST 2015

I am responding to a message that is cut and pasted below:

Message: 1
Date: Tue, 1 Sep 2015 07:55:01 -0700
From: Stanley Stanukinos <ka5iid at swbell.net>
To: arm-allstar at hamvoip.org
Subject: [arm-allstar] Newby instructions for playnews
         <1441119301.13682.YahooMailBasic at web184304.mail.ne1.yahoo.com>
Content-Type: text/plain; charset=us-ascii

Thanks to Doug for his wonderful work on the playnews script and help from 
others I was able to get it operational on my node.
I am going to list the steps in order I used so someone can follow that 
has linited Linux experience and make it work.


I first want to say thanks to Doug and everyone who helps develope the 
software for all of their effort and hard work.

I tried the scripts today and can report the following:

./playnews ARN NOW 41346 works perfectly

./playnews ARRL NOW 41346 does the following:
[root at BBB_Allstar ~]# cd  /etc/asterisk/local/playnews
[root at BBB_Allstar playnews]# ./playnews ARRL NOW 41346 L
Starting Download of ARRL Audio News @ 21:46:37
WARNING: combining -O with -r or -p will mean that all downloaded content
will be placed in the single file you specified.

--2015-09-02 21:46:37-- 
Resolving www.arrl.org (www.arrl.org)...
Connecting to www.arrl.org (www.arrl.org)||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 13777064 (13M) [audio/mpeg]
Saving to: /tmp/news.mp3

13,777,064  4.04MB/s   in 3.3s

2015-09-02 21:46:40 (4.04 MB/s) - /tmp/news.mp3 saved [13777064/13777064]

FINISHED --2015-09-02 21:46:40--
Total wall clock time: 3.5s
Downloaded: 1 files, 13M in 3.3s (4.04 MB/s)
Download complete @ 21:46:40
Converting from MP3 to individual ulaw format files
Creating /tmp/news.part1.wav
Creating /tmp/news.part2.wav
Creating /tmp/news.part3.wav
Creating /tmp/news.part4.wav
Creating /tmp/news.part5.wav
Creating /tmp/news.part6.wav
Converting to /tmp/news.part1.ul
Converting to /tmp/news.part2.ul
Converting to /tmp/news.part3.ul
Converting to /tmp/news.part4.ul
Converting to /tmp/news.part5.ul
Converting to /tmp/news.part6.ul
ARRL news will start NOW and use localplay (local) mode on node - 41346
Press any key to start news...
Starting in 10 seconds - Hit Ctrl C to interrupt
10 9 8 7 6 5 4 3 2 1
Playing file /tmp/news.part1.ul

Allison announces the ARRL news will begin.  Then when the first file 
should be played, Allison says "ARRL news will continue in 20 seconds" but 
nothing happens.  I press ctrl-c to exit back to command prompt.  So it 
seems to down load and convert the files correctly, but fails to play 
them.  I tried to delete the news* files in /tmp but that did not help. 
If I can provide any more useful info to help debug please let me 

Andy AB3XT

More information about the arm-allstar mailing list